原文转自hostloc“嗷嗷”大佬,本站仅做整理。

如果不想看过程、原理,直接到最底下的一键脚本

方法1

安装bt5.9

yum install -y wget && wget -O install.sh http://download.bt.cn/install/install.sh && echo y | sh install.sh

升级到专业版

wget -O update.sh http://download.bt.cn/install/update_pro.sh && bash update.sh pro

开心

>/www/server/panel/data/userInfo.json
/etc/init.d/bt restart

反正就这样就可以装付费插件了,到期时间显示当天

请输入图片描述

还有一种方法(方法2)
先正常安装5.9.2专业版,然后用5.9.0的common.py替换5.9.2的,再按照网上流传的修改方法(164行修改为

[data = {'status' : True,'msg' : {'endtime' : 32503651199 }};])

安装bt5.9

yum install -y wget && wget -O install.sh http://download.bt.cn/install/install.sh && echo y | sh install.sh

升级到专业版

wget -O update.sh http://download.bt.cn/install/update_pro.sh && bash update.sh pro

替换common.py

cd /www/server && cp -r panel panel-bak
wget http://download.bt.cn/install/update/LinuxPanel-5.9.0_pro.zip
unzip -o LinuxPanel-5.9.0_pro.zip panel/class/common.py
rm -f LinuxPanel-5.9.0_pro.zip

开心

sed -i "s/data = panelAuth.panelAuth().get_order_status(None);/data = {'status' : True,'msg' : {'endtime' : 32503651199 }};/" /www/server/panel/class/common.py
>/www/server/panel/data/userInfo.json
/etc/init.d/bt restart

这样的话,就是显示2099年到期了

请输入图片描述
————————————————

不管你用不用的上,建议把这几个老版本下载保存一份

脚本
http://download.bt.cn/install/install.sh
http://download.bt.cn/install/update_pro.sh

面板文件
http://download.bt.cn/install/update/LinuxPanel-5.9.0.zip
http://download.bt.cn/install/update/LinuxPanel-5.9.1.zip
http://download.bt.cn/install/update/LinuxPanel-5.9.2.zip
http://download.bt.cn/install/update/LinuxPanel-5.9.0_pro.zip
http://download.bt.cn/install/update/LinuxPanel-5.9.1_pro.zip
http://download.bt.cn/install/update/LinuxPanel-5.9.2_pro.zip

主要是安装脚本和5.9.0和5.9.2这三个
http://download.bt.cn/install/install.sh
http://download.bt.cn/install/update/LinuxPanel-5.9.0_pro.zip
http://download.bt.cn/install/update/LinuxPanel-5.9.2_pro.zip

——————————————————————————————

一键脚本

确保有wget和unzip

yum install -y wget unzip
apt install -y wget unzip

方法1

以下代码一起复制粘贴回车

yum install -y wget && wget -O install.sh http://download.bt.cn/install/install.sh && echo y | sh install.sh && \
wget -O update.sh http://download.bt.cn/install/update_pro.sh && bash update.sh pro && \
>/www/server/panel/data/userInfo.json && \
/etc/init.d/bt restart && /etc/init.d/bt default

方法2

以下代码一起复制粘贴回车

wget -O install.sh http://download.bt.cn/install/install.sh && echo y | sh install.sh && \
wget -O update.sh http://download.bt.cn/install/update_pro.sh && bash update.sh pro && \
cd /www/server && cp -r panel panel-bak && \
wget http://download.bt.cn/install/update/LinuxPanel-5.9.0_pro.zip && \
unzip -o LinuxPanel-5.9.0_pro.zip panel/class/common.py && rm -f LinuxPanel-5.9.0_pro.zip && \
sed -i "s/data = panelAuth.panelAuth().get_order_status(None);/data = {'status' : True,'msg' : {'endtime' : 32503651199 }};/" /www/server/panel/class/common.py && \
>/www/server/panel/data/userInfo.json && \
/etc/init.d/bt restart && /etc/init.d/bt default

同时,如果想安装新版的lnmp模块,安装脚本是在线的,5.9.2面板上显示最高是1.18,实际上安装脚本和7.x是同一个,也就是7.x能装啥5.x也能装啥,只是要到终端用命令装,应该是这样:

bash /www/server/panel/install/nginx.sh install 1.19

其他模块也可以自行尝试。

-转自hostloc“嗷嗷”大佬

Last modification:October 14th, 2020 at 10:30 am